Debian Etch NetInst bug during kernel installation?

Kerry Hoath kerry at
Sun Dec 30 19:38:00 EST 2007

I am aware of the bug of which you speak; there are a couple of work arounds 
you can use to minimize the affect of the strange behaviour.
Your problem with tasksel could possibly be related to the fact that you may 
not have had a working set of Debian mirrors in sources.list or for some 
reason your machine could not update the list of available packages.
Running tasksel without having sensible output from apt-get update or 
similar won't be able to install a lot of the necessary packages.

Grep is tagged essential; however less is not; more is installed on a 
standard system.

If you reduce your priority to medium when installing; i.e.
speakup speakup_synth=xxxx debconf/priority=low

you should be asked about which kernel you'd like to install.
I'm not entirely sure what triggers the behaviour you speak of; however I 
have seen the install remove the kernel from the list of to be installed 
packages rendering the system unbootable.

Note that if you are rerunning an install; just installing over the top is 
not necessary garanteed to work since other files could be left behind from 
the previous install; best to reformat the partitions containing the root 
file system, usr and var unless you know exactly what you're doing and don't 
mind cleaning up by hand afterwoods.

Regards, Kerry.

----- Original Message ----- 
From: "Gaijin" <gaijin at>
To: <speakup at>
Sent: Monday, December 31, 2007 4:51 AM
Subject: Debian Etch NetInst bug during kernel installation?

> Hello all,
> Tried installing Etch a number of times.  The first time I did
> it without allowing the root user and it installed just fine, but I
> couldn't su into the root status, or whatever they're trying to do, so I
> reinstalled Etch.  The second time around, it asked to install the
> kernel again and it wouldn't take.  I tried re-installing a third,
> fourth, and fifth time and finally got it on the sixth by skipping
> tasksel, and while trying to install the GUI, it crashed and broke
> syslogd and wouldn't start for nothing.  I was wondering if anyone had
> any tips for getting past the bug.  If I hadn't already done it once on
> the first installation, I would think it couldn't be done.  The
> post-installation version of tasksel seems broken, as most of the core
> features were never installed.  Standard features like less and grep
> were missing, and the post-installation version of tasksel didn't offer
> the choice.  Anyway, I'm about to try again and see if I can't run
> tasksel off Shane's netinst CD from another console while it might still
> be available.  I absolutely love the latest cursor tracking features in
> the 2.6 kernels.  Thanks in advance for any suggestions,
> Michael
> _______________________________________________
> Speakup mailing list
> Speakup at

More information about the Speakup mailing list