error message on startup

Georgina gena at
Wed Nov 21 09:08:18 EST 2001


Well, firstly let me apologise for stating the read only flag when it
appears that it should be the read write flag.  So change your line to
finish with rw.

Right I asked what files you added to the unzipped ZipSpeak.  I suggested
dectlk because that could be your image file for ZipSpeak.  Or you might
have a vmlinuz image file as the batch file suggests.  I also see that you
didn't specify the path to the image file.  If for example, you have a
dectlk image file and you have your batch file in your root directory the
batch file would look something like this:

@echo off
cd d:\linux
loadlin dectlk root=/dev/hdb1 rw

This is only an example.  It is assuming that your ZipSpeak is unzipped on
d: or /dev/hdb1 i.e. it is the second ide device the slave of the primary
controller.  Although if it is the incorrect address that is the problem,
you should still get speech.  I guess you need to tell us what files you
have as your kernel image and what version of ZipSpeak is it your using?  I
suggested dectlk because from memory that was the DecTalk patched kernel
image for kernel 2.2.16.

Perhaps you did read the documentation and rename the dectlk file to
vmlinuz, then you should state that in your batch file.

-----Original Message-----
From: speakup-admin at
[mailto:speakup-admin at]On Behalf Of Glenn Ervin
Sent: 21 November 2001 02:56
To: linux - speakup
Subject: error message on startup

hello group,
this is difficult...
I am using dectalk on comm1.
I loaded jaws for dos and edited my file with gina's suggestion, which
included "dectlk" in the line before the word root...
d:\linux\loadlin dectlk root=/dev/hdb1 ro
the batch file seemed to echo everything in the file that was remmed out.
 I tried using
@echo off
at the top, but that created an error in the file and it did not even want
to run until I removed that line.
So I do not know if it was just a line in the file being echoed, or if it
was really telling me that I needed to edit the line root=xxx.
When I tried to read what was at the top, it scrolled past the top of the
screen and I cannot remember if there is an easy way to paus a batch file
without editing the file, perhaps with the word "pause".
Below is the file I am running...
Thanks in advance for any help, if you care to read through the following,
and I do not know if a line or 2 is not remmed out, or if notepad just
wrapped it around:

rem  Boot Linux.  You'll need to edit this file to boot the correct
rem  partition.  In the uncommented line below, edit the 'root=/dev/XXXX'
rem  to refer to the partition where you've unzipped the root Linux
rem  If you put it on a Zip disk, it'll probably be on the fourth partition,
rem  since that's how Iomega likes to format them.  If you're using a
rem  port Zip drive then see the README.ppa for more info about configuring
rem  the drive with some kernel parameters at the end of the loadlin
rem  Here are some SCSI Zip examples:
\linux\loadlin  \linux\vmlinuz  root=/dev/sda4 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/sdb4 rw
rem  These are examples of IDE Zip devices:
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda4 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb4 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdc4 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdd4 rw
rem  These examples are for an IDE hard drive:
d:\linux\loadlin dectlk root=/dev/hdb1 ro
rem d:\linux\loadlin  \linux\vmlinuz  root=/dev/hda1 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda2 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda3 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda4 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda5 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda6 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda6 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda6 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda7 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda8 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda9 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda10 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda11 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda12 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda13 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda14 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hda15 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb1 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb2 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb3 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb4 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb5 rw
rem \linux\loadlin  \linux\vmlinuz  root=/dev/hdb6 rw

O. Glenn Ervin-- (Lenny) N0YJV
Northeast Nebraska
gervin at
or My Work e-mail:
gervin at

Speakup mailing list
Speakup at

More information about the Speakup mailing list