Speakup Kernel and Orca Getting Colder.

Martin G. McCormick martin at server1.shellworld.net
Wed May 29 09:32:54 EDT 2013

	I appreciate all this information. Thank you. I am now
in the process of creating a brand new installation. I did make
one big discovery. When running the new netinstall image, I
found out that I seem to have been using the mouse port instead
of the keyboard port for a long time. It worked on the old
system but when I booted the netinstall disk, I had no keyboard
control at all.

	I moved the plug to the other port and that must be the
keyboard port because I was immediately able to type boot s and
it came up talking the first time after that.

	I had to leave for work after getting as far as
installing the base system, but I plan to select the gnome
desktop and anything else dealing with orca when I get to that
screen, probably tonight.

I hope to end up with speakup before and after orca. Should the
net gods be smiling today and I get that, I will backup that
system before doing anything else.

	As for being able to use the mouse port on the keyboard,
I am thinking the kernel may figure out what one is doing and
just work, but that may also be why I was having such odd

	If I still end up with no orca, I will download CD1 and
try from that but I bet the netinst disk will pull down the
correct desktop. Thanks for the warning.


Tony Baechler writes:
> Hash: SHA256
> Just do a fresh, new install.  I had similar problems as you're having
> with an apparently broken Orca.  Doing a dresh install solved my problems.
>  For the first time ever, I got a talking gdm3 login.
> Be aware of a couple of things.  First, you must use an image with the
> graphical installer.  The standard CD 1 works and that's what I
> downloaded.  Just press "s" after a few seconds and you get speech, but
> unfortunately no beep on boot.  Secondly, you must install the desktop
> environment at the time you install the rest of the system to get
> accessibility.  You can't install it later.  That's what happened to me
> the first time.  I installed what I thought was the
> "gnome-desktop-environment" task after system boot and I got no Orca.
> Finally, GNOME 3.X is completely different than 2.X.  I got speech when I
> logged in and I got the "Welcome to Orca" message but nothing else seemed
> to happen.  I had to press either the Windows key or Alt-F1 to get the
> overview panel to come up which seemed to talk fine, but I didn't know
> what I was doing so I didn't get very far.

More information about the Speakup mailing list