older apollo2 does not talk

Roman Vanicek vanicek at brailcom.cz
Wed Jun 14 04:58:52 EDT 2000

Hi Kirk,

thanks for the guidelines. Now what have I found out:

ROM version: it seems both Apollo and ROM are versions 2.01 (upon
issuing @? it says "2.01" twice).

One problem - Apollo port auto-detection: I have been quite vague in the
last mails about the problems with Apollo port auto-detection. After
some tests, I'd like to tell you more about it, beacause I think it
might be important.

I disconencted all the serial devices and I don't have internal
modem. No matter to which port I connected Apollo (either ttyS0 or
ttyS1) it was always found at ttyS2. (It worked (a bit) when I connected
it to ttyS0 - but this is probably because of the shared interrupt). I
have tweaked the driver to find it on the ttyS0 always for the time
which solved first part of my problem - Apollo detection (for now - for
me to be able to test it).

The second problem - timeouts: You are absolutely right: I got the
message "Apolo: Timed out." I tried to change the value of the constant
to two million as you proposed but the result was the same - I only
waited longer at the boot and I got about twice as many of these

The only way I managed to get it to say at least something was to return
immediately (or after the first "if" - it's been the same) from the
wait_for_xmitr function. But when it gets to the "holding register
empty" cycle, it ends up with the time out and won't say a word.

I hope you can figure out something from this terse description (for
which I apologize) and if there is something more I could do, I'm ready
to try it.


P.S.: my kernel is 2.2.16 and I didn't have any problems in applying the
speakup (0.09) patches

Roman Vanicek				Free-b-software project
mailto:vanicek at brailcom.cz		http://freebsoft.freesoft.cz

More information about the Speakup mailing list