GRML with SpeakUp

John G. Heim jheim at
Sat Jun 18 10:51:38 EDT 2016

Just so you know ... The grml developers put those beeps in at my 
suggestion so blind people would know when the system is done booting 
and they can start typing the commands to get speech working.

On 06/17/2016 06:27 PM, Glenn wrote:
> Okay, this time it worked with the second enter, but it is like a choppy and
> very slow sound, quite unintelligible.
> It is really quite bad, and I am used to espeak and even setting the speed
> around 70, so you may know that there is something wrong here and it's not
> usable.
> I have the GRML 96 version, and it is running on an Intel NUC, with 8 GB of
> RAM.
> I burned it to an SD card.
> The speech is so bad, that I cannot make any modifications unless it is a
> basic CLI command.
> Thanks for any more info.
> Glenn
> ----- Original Message -----
> From: "Gregory Nowak" <greg at>
> To: <speakup at>
> Sent: Friday, June 17, 2016 5:59 PM
> Subject: Re: GRML with SpeakUp
> Since the method on starting software speech in grml has changed, and
> since I have no clue what old post you're following, I'll describe the
> process from the start.
> 1. Boot from your grml media.
> 2. You should hear a single beep, this is the boot menu, press enter.
> 3. After some time depending on the media you're booting from, you
>     should hear a series of beeps, which you described as
>     annoying. This is a configuration menu, just press enter to leave
>     it.
> 4. You should now be at a root prompt. Here you can type:
> modprobe speakup_soft
> espeakup
> If all went well, you should now get speech. Sometimes I don't get
> speech when doing this. If that happens, pressing the enter key starts
> things talking for me. Good luck.
> Greg
> On Fri, Jun 17, 2016 at 05:41:37PM -0500, Glenn wrote:
>> Hi,
>> I found an old post to this list which I kept, on starting SpeakUp in
>> GRML.
>> I have tried it with both sudo and without.
>> I ran
>> modprobe speakup_soft
>> then I ran
>> espeakup
>> And I get no speech.
>> There are some rather loud and obnoxious beeps when it starts, but I
>> followed another suggestion to try:
>> alsamixer
>> and up arrow a bunch of times, and that did not help either.
>> I did:
>> speaker-test -c 2
>> and I do get sound out of the speakers.
>> Any other ideas?
>> Thanks much.
>> Glenn
>> _______________________________________________
>> Speakup mailing list
>> Speakup at

More information about the Speakup mailing list