root fs has suddenly became read only

Tyler Littlefield tyler at
Sun Aug 17 09:26:47 EDT 2008

I ran an fsck and the problem is solved. :)
Visit TDS for quality software and website production
visit the piratecafe for programming related resources:
msn: tyler at
skype: st8amnd127
----- Original Message ----- 
From: "Tony Baechler" <tony at>
To: "Speakup is a screen review system for Linux." <speakup at>
Sent: Sunday, August 17, 2008 3:30 AM
Subject: Re: root fs has suddenly became read only

> Tyler Littlefield wrote:
>> I was wondering if anyone had any ideas. everything under / is now 
>> read-only.
> Hi,
> Can you give more details?  What distro are you using?  What did you do 
> right before that happened?  Were there any messages in any logs like 
> syslog or dmesg?  Are you booting from a live CD which mounts your drives 
> as ro?  Have you ran fsck or had file system errors lately?  Did your 
> computer lock up and not shut down properly?  This is doubtful, but are 
> you using the ext2 filesystem without journaling?  Is there an error in 
> your boot scripts that prevents it from switching to mounting RW?
> _______________________________________________
> Speakup mailing list
> Speakup at
> __________ NOD32 3361 (20080816) Information __________
> This message was checked by NOD32 antivirus system.

More information about the Speakup mailing list