Espeak Problems

Steve Holmes steve at
Tue Feb 27 21:45:30 EST 2007

This is really strange.  I know I have what I believe to be the latest
version of speechd-up but --version says "0.1" but I just untarred
version 0.4.tar.gz and compiled and ran it with ./speechd-up --version
and it still says "0.1".  In any case, I can use the punctuation
controls from Speakup, being the speakup-f7 thru speakup-f10 keys and
punctuation levels do change.  I have no -t passed on the command line
either.  Makes me wonder about the version in the latest program.  Well,
I just looked at the detailed listing of the archive and speechd-up.c is
dated Oct 21, 2006 and options.h is from slightly earlier in 2006 but
the defined version number still says 0.1.:)

No such luck on espeak-generic taking punct levels yet:); I haven't
copied that conf file into my prod environment yet nor have I built it
yet, but that's for another day.:)  Anyway, I've always been able to use
speakup's punctuation level changes and took for granted that always
worked for all.  But I'm using English language too.

On Tue, Feb 27, 2007 at 11:50:02PM +0100, Hynek Hanke wrote:
> On Tue, 2007-02-27 at 14:57 -0700, Steve Holmes wrote:
> > That's interesting about the -t option.  I'm pretty sure I run
> > speechd-up with no options and I can still control punctuation with
> > Speakup's punct level controls.  You got me wondering now.:) 
> Either you are using an old version of speechd-up or you have already
> succeeded in adding the missing functionality to Speech Dispatcher
> generic output module ;)
> Without -t, speechd-up will rewrite the punctuation tables of Speakup.
> Thus punctuation can be handled in the synthesizer itself and
> internationalization and better intonation are possible.
> With Regards,
> Hynek
> _______________________________________________
> Speakup mailing list
> Speakup at

HolmesGrown Solutions
The best solutions for the best price!

More information about the Speakup mailing list