Espeak Problems

Hynek Hanke hanke at
Tue Feb 27 15:41:26 EST 2007

On Tue, 2007-02-27 at 12:05 -0800, Zachary Kline wrote:
> I did not do this, actually.  When I did, the thing works now.
> What I'm wondering is how to change punctuation settings?  I'm not getting 
> any punctuation at all spoken, and I want to get at least some.  (Changing 
> defaultpunclevel in speechd.conf didn't seem to do the trick, unless I need 
> to reboot the machine first?)


this is a problem that is being worked on. If you need just to make it
work for Speakup in English, the trick for now is to run speechd-up
with the -t (or --dont-init-tables option). Speakup will care of
punctuation, but this only works for English.

If you want internationalization, don't do this. Modify
the /etc/speech-dispatcher/modules/espeak-generic.conf (or similar path)
so that the option GenericExecuteSynth contains the --punct parameter
for eSpeak

This should work:

GenericExecuteSynth \
"echo \"$DATA\" | espeak -w /tmp/espeak.wav --punct -v $VOICE -s $RATE
-a $VOLUME -p $PITCH --stdin && aplay /tmp/espeak.wav"

Make sure GenericStripPunctChars is commented out with the # sign. (It
is by default.)

This second way works with internationalization and will likely result
in better synthesis etc. However, you will not be able to switch between
punctuation on and of at runtime.

Sorry for the hacks. We are working on it.

Have a nice day,
Hynek Hanke

More information about the Speakup mailing list