Espeak, gnome-speech and alsa

Michael Whapples mikster4 at
Mon Feb 19 06:59:20 EST 2007

To further this more, I have now tried updating to the latest portaudio19 
snapshot, this gives interesting results.

When using the espeak binary (not the speak, not tried that, so using the 
shared lib), I now have quite a long delay from pressing the enter key after 
typing the command and the speech. The latency when using gnome-speech 
doesn't seem to be increased much (if at all). When using the espeak 
command, if I have speakup speaking (using speechd-up and speech-dispatcher, 
producing sound using alsa) then espeak can start speaking across the output 
(multiple sound output, possibly success), but if espeak starts speaking 
before speakup is made to speak, then espeak blocks the sound card and 
speakup speech doesn't come through. When using gnome-speech and orca, I 
have never got it like this to produce speech and sound.

So could this be a portaudio problem? Does libespeak produce the sound (via 
portaudio) or does it give the sound data back to whatever is using the lib? 
I suppose I am getting at, is it that the gnome-speech espeak driver needs 
to support alsa for me to get sound and speech working this way, or can I do 
it by getting libespeak to use alsa?

Michael Whapples 

More information about the Speakup mailing list