Where does ESpeak log stuff normally?

Hynek Hanke hanke at brailcom.org
Sat Feb 17 08:26:06 EST 2007

Keith Hinton writes:
> I accidentally emerged an old version of Speech-dispatcher. Think it was 0.4 or something.
> Now, Speakup won't start with ESpeak anymore. I tried making:
> /var/log/speech-dispatcher, with:
> mkdir /ver/log/speach-dispatcher, but got no result, still doesn't speak.
> It won't auto-load the module, eaven though it  

Hi Keith,

First of all, are you running a recent version of Speech Dispatcher now
or are you speaking about 0.4?

I understand that your main problem is that Dispatcher is not logging to
/var/log/speech-dispatcher (the path is correct) and so you can't find
what is wrong and why you can't get any speech.

There are several reasons why logging would fail. Most likely it is a
permissions problem due to reinstalations etc. What user are you running
Speech Dispatcher under? If you are running Debian, it will be the user
speech-dispatcher. Does this user have access write rights
to /var/log/speech-dispatcher/ and the files inside?

Please try to run Speech Dispatcher as
	speech-dispatcher -s - l 3

This will execute it on the foreground with normal logging level. If it
fails to write into the logfile, it will write its messages on the
terminal, so you can find what is wrong.

> Here is the modules section of /etc/speech-dispatcher/speechd.conf
> AddModule "flite" "sd_flite" "flite.conf" "/var/log/speech-dispatcher/flite.log"
> AddModule "espeak-generic" "sd_generic" "espeak-generic.conf" "/var/log/speech-dispatcher/espeak.log"
> DefaultModule espeak-generic

Looks ok.

> Is that information correct? Why does ESpeak still not speak eaven with speech-dispatcher
> and speechd-up running, and the /var/log/speech-dispatcher log created? I note nothing
> exists in it whatsoever...

Please examine its change date. I suspect the logfile is old and the
instances of speech-dispatcher you are executing can't write their own
logs. Also run
	ps -A | grep speech
and see if Speech Dispatcher is running.

Write again with this new information if you can't fix the problem.

With Regards,
Hynek Hanke

More information about the Speakup mailing list