Where does ESpeak log stuff normally?

Keith Hinton keithint38 at CommSpeed.net
Sat Feb 17 07:26:36 EST 2007

I accidentally emerged an old version of Speech-dispatcher. Think it was 0.4 or something.
Now, Speakup won't start with ESpeak anymore. I tried making:
/var/log/speech-dispatcher, with:
mkdir /ver/log/speach-dispatcher, but got no result, still doesn't speak. It won't auto-load the module, eaven though it     resides in: /etc/speech-dispatcher/modules/
Or perhaps it was: /etc/speech-dispatcher/clients/modules?
Here is the modules section of /etc/speech-dispatcher/speechd.conf

AddModule "flite" "sd_flite" "flite.conf" "/var/log/speech-dispatcher/flite.log"

#AddModule "festival" "sd_festival" "festival.conf" "/var/log/speech-dispatcher/festival.log"

AddModule "espeak-generic" "sd_generic" "espeak-generic.conf" "/var/log/speech-dispatcher/espeak.log"

#AddModule "epos-generic" "sd_generic" "epos-generic.conf" "/var/log/speech-dispatcher/epos.log"

#AddModule "dtk-generic" "sd_generic" "dtk-generic.conf" "/var/log/speech-dispatcher/dtk-generic.log"

#AddModule "ibmtts" "sd_ibmtts" "ibmtts.conf" "/var/log/speech-dispatcher/ibmtts.log"

#AddModule "cicero" "sd_cicero" "cicero.conf" "/var/log/speech-dispatcher/cicero.log"

# The output module testing doesn't actually connect to

# anything. It outputs the requested commands to standard output

# and reads responses from stdandard input. This way, Speech Dispatcher's

# communication with output modules can be tested easily.

# AddModule "testing"

# DefaultModule selects which output module is the default.

# You must use one of the modules loaded with AddModule.

DefaultModule espeak-generic

Is that information correct? Why does ESpeak still not speak eaven with speech-dispatcher and speechd-up running, and the /var/log/speech-dispatcher log created? I note nothing exists in it whatsoever...



More information about the Speakup mailing list