[raspberry-vi] A bit off topic, Speakup and Debian Stretch-Buster (fwd)

Gregory Nowak greg at gregn.net
Tue Mar 24 19:14:01 EDT 2020

On Tue, Mar 24, 2020 at 11:40:56AM -0500, Glenn K0LNY wrote:
> I have a Raspberry PI Model B, version 2, and I'm trying to get eSpeak and
> speakup going.
> I installed the version:
> 2020-02-13-raspbian-buster.img
> and I can SSH into it, and I was getting audio out with:
> speaker-test -c 2
> but if I tried espeak "hello"
> I didn't get anything until I installed pulseaudio.
> Now the espeak works, but still no speakup on boot-up.
> I installed speakup and that did not work, although it seemed to install
> okay.

I assume you mean espeakup, not speakup. I haven't used speakup on a
rpi since raspbian/devuan jessie. However, I do recall back then that
espeakup didn't work properly through the on board sound chip, and
Michael Ray I believe posted work arounds for that. I don't know if
the situation has changed since. I don't think espeakup and pulseaudio
will play any nicer on the rpi than they do on the PC. My solution
back then was to install speechd-up, and get output from speakup that way.

> I installed Orca with:
> apt-get install gnome-orca
> and that seemed to install okay, but it did not help speakup.

First, I don't see how installing orca is supposed to help speakup,
since they're separate screen readers using different interfaces to
provide speech output. Second, last time I checked, raspbian was using
their own slimed down desktop environment not using gtk, so that
wouldn't work with orca. I don't know if that has changed since
either. If it hasn't, your best bet is probably to install raspbian
light, and then manually install mate or xfce. It will be slow almost
to the point of not being very useful in my opinion, but it should
work. I think gnome is too bloated for the rpi, but I could be wrong there.

> I had done a general Debian update before doing all the above.
> The only way eSpeak works with strings of text is via SSH, not the plugged
> in keyboard.

Is the rpi recognizing the keyboard when you plug it in? Are you sure
you successfully logged in on a text console before attempting to run
espeak from the keyboard?

> I would like to get a desktop going, but this RPI may not have the RAM for
> it.

I tried mate on a rpi 3 back when I was using devuan jessie. It worked
as proof of concept, but browsing with firefox brought the unit to its
knees on most sites. A rpi2 might not have the RAM for a full GUI like
mate, but I could be wrong there too.


web site: http://www.gregn.net
gpg public key: http://www.gregn.net/pubkey.asc
skype: gregn1
(authorization required, add me to your contacts list first)
If we haven't been in touch before, e-mail me before adding me to your contacts.

Free domains: http://www.eu.org/ or mail dns-manager at EU.org

More information about the Speakup mailing list