Problem with apollo II on dell power edge t20

John G Heim jheim at
Tue Jul 5 18:07:31 EDT 2016

You could try a kernel patched to avoid the serialio bug. This bug 
causes speakup to fail to load the driver for some serial port 
synthesizers because the port is flagged as in use by the linux kernel. 
You can modify the kernel code to make it ignore the flag. The drivers 
for some hardware synths never bothered with that flag so that may not 
be your problem. You would have to examine the code to know.

I wrote a script for debian systems  that builds a patched kernel. As 
far as I know, it works only on debian systems.  You can download the 
script at:

This script does the following:
1. Installs packages necessary for building a kernel.
2. Downloads kernel source from debian (not
3. Downloads and installs a patch I created for 3.16.7 kernels.
4. Compiles a pathed kernel and creates debian deb packages .

You must then install the kernel with dpkg.

On 07/05/2016 12:38 PM, Dietmar Segbert wrote:
> Hello,
> since a kernel update at the begin of 2016, my apollo 2 will not speak
> with me.
> I use debian jessie with a 3.6.x kernel, 32 bit.
> Regards
> Dietmar
>> wulfryk1 at schrieb am 05.07.16:
>> Before i posting i suspected  that the problem isn't in the speakup
>> itself, but in my power edge. Is there anything, which i  can tried to
>> make speakup working with my machine with my apollo II.
>> --
>> Lukasz Golonka <wulfryk1 at>
>> On Fri, 01 Jul 2016 08:41:38 -0500
>> John G Heim <jheim at> wrote:
>>> You can use the very same live CD on one machine and it works but it
>>> does not work on another machine? That strikes me as very strange. There
>>> has been a bug in speakup for a long time where it can't allocate the
>>> serial port because the kernel says it's in use. For years, people have
>>> been hacking the kernel code to bypass the problem. But if the very same
>>> CD works on one computer and not on another, this is not that.
>>> On 07/01/2016 05:31 AM, Lukasz Golonka wrote:
>>>> Hello,
>>>> i have tried to use my apollo II externall synthesier with speakup on my
>>>> dell power edge t20. Unfortunatelly after executing modprobe
>>>> speakup_apollo there is the message "can not insert speakup_apollo no such
>>>> device. I'm sure that linux work with my serial port, because i'm able to
>>>> type echo test >> /dev/ttyS0 and hear apollo speaking There isn't also a
>>>> problem  with distro which i'm using,, because i'm able to use the same
>>>> live cd with apollo on another machine.
>>>> Thanks for any help
>>>> Greetings
>>>> Lukas
>>>> _______________________________________________
>>>> Speakup mailing list
>>>> Speakup at
>>> --
>>> --
>>> John G. Heim; jheim at; sip://
>>> _______________________________________________
>>> Speakup mailing list
>>> Speakup at
>> _______________________________________________
>> Speakup mailing list
>> Speakup at
> _______________________________________________
> Speakup mailing list
> Speakup at

John G. Heim; jheim at; sip://

More information about the Speakup mailing list