Slack 13.37 and 14.0

Tony Baechler tony at
Tue May 14 05:10:24 EDT 2013

Hash: SHA256

Since no one answered, I'll try my luck.  I don't use Slackware and
haven't in a very long time.  If you're using hardware speech, Slack
probably ships a newer kernel after 2.6.37 with broken serial support.
The only two options are to use an older kernel or software speech.  I
don't think Slackware supports software speech, but Debian does.  If
you're running 32-bit, you might run into problems with big drives
regardless of the kernel.  I would recommend installing 64-bit Debian
Squeeze if your system can run 64-bit and upgrade to Wheezy from there.
That still lets you use the older kernel with hardware speech while giving
you the newer packages.  If you can use software speech, of course just
installing Debian Wheezy directly is the better option.  I've ran both
Debian Squeeze with the 2.6.32 kernel and Wheezy with the 3.2 kernel and
several 3 TB drives in a RAID array with no problems.  As I'm sure you
know, you probably don't want to use a 3 TB drive for boot.  I have a
separate 1 TB RAID array for my boot drive and I've had no problems.

In reading your message again, I have a question.  What happens with
Debian if you use the standard Speakup keys to change your rate and pitch?
 I use a DECtalk Express here and I've never had that problem.  In fact, I
worked on fixing the driver and William incorporated my fixes with his own
into the official Speakup module, so you should have a very good
experience.  Someone else has reported random rate and pitch drops, but
he's using a DECtalk USB.  I'm assuming you tried either the speakupconf
script in the speakup-tools package or added lines to /etc/rc.local to set
your rate and pitch, right?  If the standard Speakup keys aren't working,
you might have a keyboard issue or there might be a bug in D-I.  Did you
actually get Debian installed or is the problem you're having with the
install CD?

On 5/13/2013 10:06 AM, Mitchell D. Lynn wrote:
> New to this list and hoping you all can help with this problem.  I am
> having issues with the last two versions of Slackware and getting
> Speakup at install time. I have used Slackware back to version 7.0 with
> no issues.
> For some reason, I can't get Speakup to load on either of these
> releases. Using DEC Talk Express. Tried speakup.s, huge.s and hugesmp.s
> since the latter two appear to have Speakup as well.
> I desperately need to get to a version that supports 3TB hard drives. 
> Considered switching to Debian, but ran into a Speakup issue there
> too. Seems to be stuck at a default rate, and it won't let me change it
> for session or otherwise.
Version: GnuPG v1.4.11 (MingW32)
Comment: Using GnuPG with Thunderbird -


More information about the Speakup mailing list