Steve Holmes steve at holmesgrown.com
Sat May 7 15:16:26 EDT 2011

I've been through some major upgrades recently with my arch box and
thankfully nothing broke speakup.  I did run into some big problems
with speech and gnome3 largely because of the use of pulse audio
<yuck>.  In fact, you might try and configure your system to not
launch gnome at all for the time being and see if you can at least get
speakup going again.  then if that does the trick, then look into the
file, /etc/asound.conf; might wanna copy this to your home directoryh
and anywhere else you might be running pulse like in gnome.  Comment
out all the contents so pulse won't try to override your ALSA stuff.
this will enable espeakup and espeak to function under ALSA instead of
pulse.  I think there are some changes that need to be made to the
default.pa file in /etc/pulse too but don't know the exact tools.
this pulse audio business has introduced a log of additional
challenges and unnecessary hassles to getting a machine up and
talking.  Sorry I don't have the specific info for pulse configuration
but I'll bet pulse audio is biting you here.  the gnome 3 upgrade that
took place last weekend forced an install of pulse audio if not
already there.

On Wed, May 04, 2011 at 12:53:49PM -0400, aerospace1028 at hotmail.com wrote:
> I appologize in advance for the lengthy post and its off-topic nature.  I thought maybe some of the arch users here might be able to help me find out the source of some troubles I am having.
> My machine has been running slowly since I upgraded last Friday (April 29).  I tend to update once a week, on Friday morning.  I am on a single CPU 
> (single core AMD) laptop, duel-booting with WindowsXP.
> I ran the update in two steps, "pacman -Syy" followed by "pacman -S --noprogressbar -u".  pacman.log lists the altered packages as follows.
> [2011-04-29 08:49] upgraded curl (7.21.4-2 -> 7.21.6-1)
> [2011-04-29 08:49] upgraded espeak (1.44.05-2 -> 1.45.03-1)
> [2011-04-29 08:49] upgraded gnome-mplayer (1.0.2-2 -> 1.0.3-1)
> [2011-04-29 08:49] upgraded gnutls (2.12.2-1 -> 2.12.3-1)
> [2011-04-29 08:49] >>> Updating module dependencies. Please wait ...
> [2011-04-29 08:50] ==> SUCCESS
> [2011-04-29 08:50] upgraded kernel26 ( ->
> [2011-04-29 08:50] upgraded libfetch (2.33-1 -> 2.33-3)
> [2011-04-29 08:50] upgraded libmad (0.15.1b-4 -> 0.15.1b-5)
> [2011-04-29 08:50] upgraded mdadm (3.2.1-1 -> 3.2.1-3)
> [2011-04-29 08:50] upgraded raptor (1.4.21-2 -> 2.0.2-1)
> [2011-04-29 08:50] installed raptor1 (1.4.21-3)
> [2011-04-29 08:50] upgraded rasqal (0.9.21-1 -> 1:0.9.21-1)
> [2011-04-29 08:50] upgraded redland (1.0.12-6 -> 1:1.0.12-1)
> After the update completed, orca, on the gnome-desktop, began slurring words together, but speakup was fine.  I presumed there was something going on 
> with the espeak update, so I rebooted the machine.
> The machine rebooted as normal, the grub menu popped up and I launched into archlinux.  As normal, a mess of boot text scrolled across the screen.  Then the 
> screen cleared and the modules and daemons messages started popping up as normal, but it seemed to hang here and speakkup wasn't talking yet (I use 
> speakup_soft loaded as a module).
> I presumed after 10-15 minutes that the machine had frozen and rebooted again.  Again the boot process stalled where speakup would normally kick in 
> (usually saying something like "mounting network busy done.  loading iptables busy done" etc.).  After i presumed it had frozen again, I alt-arrowed 
> over to where gnome would be, if the system had loaded propperly (just to see if there was anything there: tty7).  When I navigated back to tty1, 
> speakup kicked in and the boot process completed.  Much of the computer, still appeared sluggish: loggin at gdm took forever, even logging in at the 
> text terminals took a noticable second or two.
> subsequent boot-ups and shut-downs have consumed varying, but ab-normally longer, amounts of time.  It's now faster to boot into windows than arch.  The 
> case used to be reversed.
> There have been other oddities.
> The clock seems quite messed up.  While I am actively using the machine, the time appears to update normally; but if I walk away for a few minutes and 
> the machine goes idle, the time freezes and continues when I am actively using the machine.  This is both the time relayed through orca on the desktop 
> (using the python function I wrote when I first started using orca a couple of years ago) and with the date command in the text-terminals.  However this 
> anomaly is absent.  This has never been a problem before.
> Before the upgrade, when the machine went idle, the screen would go dark, but now it stays active, until I poweroff the machine.  Also the screen-saver 
> never engages on the desktop.  Again, this appears to be a linux phenominon, not present in Windows.
> I'm not sure what the root-cause of my problem is.  The best i could guess is something with the kernel upgrade, but I've never had any trouble with 
> kernal upgrades before.  I have not cleaned out my package cache yet (once or twice a month I run "pacman -Sc).  The old kernal package archive is still 
> there: would a "pacman -U" on that file downgrade the kernal?  Is it worth a try?  Does anyone have any clue where else I can look to find out what's 
> going on? 		 	   		  
> _______________________________________________
> Speakup mailing list
> Speakup at braille.uwo.ca
> http://speech.braille.uwo.ca/mailman/listinfo/speakup

More information about the Speakup mailing list