Serial conflict

Jacob Schmude j.schmude at
Wed Mar 2 01:56:14 EST 2011

Hash: SHA1

Doesn't work, unfortunately. I do have it sort of working with the git
version (staging isn't working) but not the way it should be. Speakup
and the kernel's serial driver constantly battle over it. Seriously,
this is 2011. One would think we'd be over having to recompile kernels
for things like this.

On 03/01/2011 10:46 PM, covici at wrote:
> Once you delete that return statement, you have to recompile the
> kernel -- in 2.6.37 I would using the staging driver instead of
> git. This works for me , at any rate.
> Jacob Schmude <j.schmude at> wrote:
>> Hi all, Well, it's been a while but here I am again to stir up a
>> bit of trouble. <grin> I'm attempting to use Speakup with a
>> serial synthesizer on Archlinux with kernel
>> (2.6.37-ARCH is the in-kernel version number). Speakup is
>> included in these kernels, but trying to load any of the speakup
>> synthesizer drivers results in the following: synth probe Ports
>> not available, trying to steal them Trying to free nonexistent
>> resource <00000000000003f8-00000000000003ff> Unable to allocate
>> port at 3f8, errno -16 LiteTalk: not found ltlk: device probe
>> failed
>> This happens with any serial synth I have, though obviously
>> substitute the other driver names in these errors. I've tried the
>> Doubletalk LT, Dectalk Express, and Accent SA (yes, all of which
>> I do have). I get the same result whether I allow Speakup to
>> probe or whether I specify a ser=0 parameter. I've trieed a few
>> things. First, I tried unbinding the in-kernel serial driver from
>> that port via sysfs, but there's no change although the port does
>> seem to successfully unbind. Second, I searched the speakup
>> archives and found a post from January detailing this problem,
>> and the poster had success removing the return NULL statement at
>> that point in serialio.c. This didn't work for me, however, and
>> I'm not all that surprised it didn't. I've tried the staging
>> speakup in the kernel, and with the latest git. The return NULL
>> removal was attempted on the git source tree. Can anyone shed a
>> bit of light on what I'm probably doing wrong? I can compile a
>> custom kernel if necessary, though I was hoping not to need this.
>> It worked in kernel 2.6.36, but obviously something critical has
>> changed.
>> Thanks
>> _______________________________________________ Speakup mailing
>> list Speakup at

Version: GnuPG v1.4.11 (GNU/Linux)


More information about the Speakup mailing list