modprobe speakupmain hangs

Hynek Hanke hanke at
Wed Nov 1 09:47:14 EST 2006


we are experiencing a problem with the speakupmain module (the latest
CVS versions with 2.6.18 kernel) on at least one machine here in
Brailcom. I can't say much about it except for this:

1) Our target configuration is Speakup with the sftsyn module. We tried
to load the modules separately and we are sure the hang happens because
of the speakupmain module.

2) The modprobe hangs every time we try to do
	modprobe speakupmain
and when it hangs, the /dev/sftsyn device is still not intialized.

3) After we killall modprobe, the /dev/sftsyn device appears and there
comes a notice about it in syslog. The module stays loaded. It is then
possible to load speakup_sftsyn and Speakup works just fine. I'm not
sure if something is not missing in /proc/speakup or somewhere, but we
didn't notice anything strange.

4) Trying to increase modprobe verbosity or kernel logging level reveals
no additional information. gdb shows that the hang happens inside the
module_init() function in modprobe.

Our workaround is (which also illustrates the issue):
	modprobe speakupmain &
	sleep 1
	killall modprobe
	sleep 1
	modprobe speakup_sftsyn

We would appreciate some help with this or some guidance about how could
we get more information about it. Also, does someone else experience
this issue?

Thanks a lot,
Hynek Hanke

More information about the Speakup mailing list