Compiling My Kernel -- still having trouble

Gregory Nowak greg at
Mon Jun 14 14:00:10 EDT 2004

Hash: SHA1

If I understand you correctly, you're applying speakup 1.5 to a fresh
kernel source tree, and then applying cvs speakup to that. If so, then
don't do that, apply cvs speakup directly to a fresh kernel source

Also, if you're up to it, move up to the newest 2.4 kernel, which is
2.4.26, since 2.4.22 has some security issues. If you're not up to it,
then I would recommend that you get your build of 2.4.22 working first
entirely, then use make oldconfig with your 2.4.22 config file to
upgrade to 2.4.26. 

Also, why are you using telnet instead of ssh, since ssh is more


On Mon, Jun 14, 2004 at 10:23:06AM -0700, Debee Norling wrote:
> I spent most of my weekend trying to compile a Speakup-enabled kernel. The
> good news is I compiled several stock kernels, without speech and without
> errors. I can boot them; they locate and support all my hardware fine. I can
> telnet in to the machine and even mount my USB flash drive.
> But I get errors every time I try to patch in Speakup.
> I have been careful to completely remove the entire source tree and untar a
> brand-new tree to /usr/src. I create the soft link so linux-2.4.22 points to
> /usr/src/linux. This is Slackware 9.1, kernel version 2.4.22. I've tried
> using the source tree that is part of my distro; also downloaded a new
> 2.4.22 tree from
> I tried installing Speakup 1.5 and I also tried getting the 2.26 from CVS. I
> tried doing the 1.5 first, then the cvs patches.
> If I ignore the patching errors and do make oldconfig, I am prompted for the
> new things, like all the synthesizers, including the Dectalk ISA card. The
> speakup directory is there under /usr/src/linux/drivers/char,  and lots of
> source and header files are there as well. But of course, this patched
> kernel doesn't compile.
> I've read all the documentation I could find and that was recommended on
> this list, but I'm obviously missing something.
> Here's a snip from the patching output:
> U speakup/diff-v26/include^linux^speakup.h.copy
> Creating .orig files [..................] done.
> Patching files [pppppppppp1 out of 3 hunks FAILED -- saving rejects to file
> /usr
> /src/linux/drivers/char/Makefile.rej
> ppppppp] done.
> Copying files [ccccc] done.
> --Debee
> _______________________________________________
> Speakup mailing list
> Speakup at
> !DSPAM:40cde61a72801043536507!

- -- 
Free domains: or mail dns-manager at

Version: GnuPG v1.2.3 (GNU/Linux)


More information about the Speakup mailing list