bad inodes on initrd

Igor Gueths igueths at
Mon Nov 4 20:50:38 EST 2002

Hi all. When attempting to create a bootable Woody Cd, I get so far as to
boot the kernel and getting it up talking. After it mounts the root_fs on
the ramdisk, I start getting errors about bad inodes starting at about
2945 and going up to 2949. I would paste the messages I get in this post,
however I am unable to capture them because they eventually scroll offf
the screen. The reason being that after the inode errors sease displaying,
dbootstrap attempts to start and open /dev/tty1, and /dev/tty2. This
doesn't work because the root filesystem was not properly mounted. As a
result, the console devices are deamed nonexistant by the kernel. I tried
re-creating the filesystem and copying all the files from the root.bin of
the original iso into the newly created ext2_fs. This didn't work. I also
tried changing linuxrc to a different executable (init). Anyone have any
other ideas I should try? Thanks!

May you code in the power of the source,
may the kernel, libraries, and utilities be with you,
throughout all distributions until the end of the epoch.

More information about the Speakup mailing list