Linux hanging when trying to set serial port.

Joseph Norton jnorton at
Tue May 16 06:22:00 EDT 2000

Hi all:

Yesterday, I was talking with David Poehlman (whom some of you know if
you're on blind-l) and he's having a problem using Zipspeak (aka
Zipslack) related to serial ports.

His modem is a plug and pray modem.  The modem is assigned to com3, IRQ
5.  I told him what worked in my case and it locked up when booting.  The
synth is an Accent SA on com1 (I think).

Here's what I suggested to him.  I do not have a serial synth I use
normally, so, I never tried this with a synth running on com1.  There's
probably something I'm overlooking, so, any of you feel free to jump in
and correct me.  


----------Forwarded Message-----------

Ok.  I think this will work (it worked for me anyway).

First, you'll need to uncomment a line in the file "rc.S" (note the
upper-case 'S' in this filename).  This file is located in the "/etc/rc.d"
directory.  The line should look like this:

# . /etc/rc.d/rc.serial

Just remove the number-sign (#) from in front of the line.  Then, save
this file.

Now, you'll need to uncomment the line that refers to your serial port
(Com3) in the "serial.conf" file.  This file is located in the
"/etc" directory.  You'll also need to make sure the IRQ and UART type are
correct (hopefully the i/o address will also be right).  The line you'll
need to uncomment and modify will probably look like this:

#/dev/ttyS2 uart 16450 port 0x3E8 irq 4

Again, just remove the number-sign from in front of the line and modify it
with the appropriate information.  Hope this helps.

More information about the Speakup mailing list