please help with legacy grub

Steve Holmes steve at
Sat Feb 12 16:11:46 EST 2011

If this machine is that old, you might have to fall badck to something
like Slackware 12.1 or before.  I have a couple machines that none of
the new images will boot on but I could always get this old Slackware
disk to do it.  I think it is 12.1 or before.  if 12.1 doesn't work,
then try 12.0; that will work for sure.  Anything later than that
would not work on either of these older machines.

On Thu, Feb 10, 2011 at 07:29:15PM -0700, Gregory Nowak wrote:
> Hash: SHA1
> Christopher and all,
> On Thu, Feb 10, 2011 at 07:57:43PM -0500, Christopher Moore wrote:
> > First, there is a grub rescue floppy disk which should help you fix your grub problems.  You might need sighted assistance to run it.  I forget the name
> > , but you can google it.
> Yes, it's called supergrub, and the need for sighted assistance is why
> I haven't tried it, at least not yet.
> > 
> > Second, in the old days, we were able to copy the vmlinuz image to a floppy with dd and boot from it.
> > 
> Yes, however, I seem to recall reading somewhere that new kernels
> don't support doing that anymore. Even if they do, the initrd won't
> fit on a floppy, and without the initrd, there's nothing that I could
> really do.
> > Third, when grub doesn't boot successfully, you can get into a shell prompt.  This allows you to use many of the normal shell commands to help determine 
> > what went wrong.  In particular, you can mount devices and move/copy files.  Again, you won't have speech.  
> Yes, I've tried getting into that, like I described in my first post,
> but without sighted help.
> > 
> > Finally, save yourself from further headaches and trash the machine.
> Yes, that thought has crossed my mind too, but even though software
> speech is all fine and good, there's still some part of me that
> refuses to let go of my doubletalk pc as long as it still works, and
> as long as I have a machine to use it in. Some might think this silly,
> I know.
> Thanks for all your ideas everyone, they're much appreciated. I have
> an old version of systemrescuecd lying around here somewhere, which I
> seem to recall works on this system. If that's correct, then hopefully
> it won't be too old for me to be able to chroot into the system on the
> hd with it. If it is, then I thought I could use it to upload the
> kernel, and initrd to another machine on my lan, and use isolinux to
> boot with them. I'll post back with whatever finally happens for the
> record, but since this machine isn't a priority, and since getting it
> bootable again looks like a somewhat complex project, that may not be
> soon. Thanks again.
> Greg
> - -- 
> web site:
> gpg public key:
> skype: gregn1
> (authorization required, add me to your contacts list first)
> - --
> Free domains: or mail dns-manager at
> Version: GnuPG v1.4.9 (GNU/Linux)
> iEYEARECAAYFAk1UnvsACgkQ7s9z/XlyUyBPnQCgpK+pDwKxar/eIA5fxAuxDuwI
> Iy4AoIVp7RpKHjbsIO8gQvPXq6IgSpqP
> =O0DS
> _______________________________________________
> Speakup mailing list
> Speakup at

More information about the Speakup mailing list