Speakup and locales

Hermann meinelisten at onlinehome.de
Thu May 28 16:28:15 EDT 2009

am Do 28. Mai 2009 um 22:04:07 schrieb William Hubbs <w.d.hubbs at gmail.com>:
> Hash: SHA1
> Hi Hermann,
> On Thu, May 28, 2009 at 09:27:45PM +0200, Hermann wrote:
> >> Actually, there is an easier way to do this.  As root, do the following:
> >>
> >> echo 1>  /sys/module/speakup/parameters/direct
> >>
> >> This will allow espeak to handle character pronunciation instead of
> >> speakup.  This feature is still in its early stages, so let us know if
> >> you have issues with it.
> >>
> > I saw this on an earlier message by you on this list and tried it without 
> > success:
> > I get the message: "No such file or directory".
> > What does this command do? I guess it creates a file?
> No, there should be a file there by that name, and it sets a value in
> that file.
> Try this as root:
> cat /sys/module/speakup/parameters/direct
> The output should be 0 or 1.
Neither nor: "No such file or directory".
It seems as if I have no permission accessing this directory; but I'm root.
I created the file in my root's directory and tried to move it, same 
Note: I tried this with a GRML 2009-05-RC1 CD, and it works besides the 
fact that the umlauts and most of the punct chars are not spoken at all. 
However the Espeakup version is still 0.4 on this distro.

> Also, get the output of this command:
> cat /sys/module/speakup/parameters/version
> and let us know what that output is.
Speakup version 3.0.3
soft synthesizer driver version 2.4


More information about the Speakup mailing list