Creating a Custom Kernel on Debian

Robert Spangler spangler.robert at
Mon Aug 4 22:56:41 EDT 2008

That's what is weird - I did.  I used  I'll 
investigate it more later - maybe kernel-package is doing something funny?

Gregory Nowak wrote:
> Hash: SHA1
> It sounds like you may be using the debian sources, since you
> mentioned a package. I know that it's normal for what you describe to
> happen when you do oldconfig, and you don't have a .config file in the
> kernel source directory, I've never heard of that happening with
> menuconfig, unless this is a debian thing like you said. What I wanted
> to mention, in case you weren't aware of it, is that you don't have to use the debian sources to build a custom
> kernel using kernel-package if you don't want to. I personally use the
> standard sources from
> Greg
> On Mon, Aug 04, 2008 at 10:34:23PM -0400, Robert Spangler wrote:
>> Hello,
>> Wow, this is odd!  I untared the linux- package, created a  
>> symlink to it, called linux, and installed a git copy of Speakup to it.  
>> When I go in and do make menuconfig, it tried to take settings out of  
>> the config file for my current kernel from /boot!  Then, I went to move  
>> that and it tried to take them from arch/x86/config or  
>> whatever....What's going on here?  Whatever happened to just plain  
>> custom-kernel building?  LOL...Unless this is a Debian thing but I don't  
>> recall reading about it.
>> Thanks,
>> Robby
>> _______________________________________________
>> Speakup mailing list
>> Speakup at
> - -- 
> web site:
> gpg public key:
> skype: gregn1
> (authorization required, add me to your contacts list first)
> - --
> Free domains: or mail dns-manager at
> Version: GnuPG v1.4.9 (GNU/Linux)
> iEYEARECAAYFAkiXvk8ACgkQ7s9z/XlyUyB7YQCgjHeoAeeOW4kDiOqN5Ik0XWhZ
> uJUAn3HH4Hd6mplllb7Ss1K8VKANTI3x
> =3694
> _______________________________________________
> Speakup mailing list
> Speakup at

More information about the Speakup mailing list