need help getting fedora 6 to boot with speech

Doug Sutherland doug at
Sat Feb 10 19:46:49 EST 2007


Okay, if disabling apic stops doubletalk, then did you
try the other suggestion instead of getting someone to
disable ACPI in BIOS settings?

One of the things that ACPI does is dynamic assignment
of interrupts (IRQs). Those kernel messages showed
failures while trying to do that dynamic IRQ assignment.
Disabling ACPI will tell the kernel to assign interrupts
the old fashioned way, like before ACPI was available.

If that doesn't work then are there any other specific
error messages? Does the system proceed to install
and just not speak, or what exactly is happening?

  -- Doug

Corey Knapp wrote:
> Hi Dug, 
> I had my girlfriend go and disable apic but now the doubletalk will not
> speak and I have tried the following things.
> 1. text speakup_synth=ltlk speakup_ser=1 and I tried 0 and 2
> It boots fine from the fedora 3 boot.iso any help would be appreciated.
> thanks in advance.
> Corey
> -----Original Message-----
> From: speakup-bounces at [mailto:speakup-bounces at]
> On Behalf Of Doug Sutherland
> Sent: Thursday, February 08, 2007 8:53 PM
> To: Speakup is a screen review system for Linux.
> Subject: Re: need help getting fedora 6 to boot with speech
> Your system is choking before it gets to anything to do with speech. The
> APIC is a programmable interrupt controller. Thats the 8259A in your system.
> The 8254 mentioned is the system timer. It appears that on boot the kernel
> is trying to register the system timer with the interrupt controller and
> it's failing.
> Note what the kernel message states: try booting with the 'noapic' option.
> This is a kernel  parameter.  They can be specified at the boot prompt.
> Suggestion 1:
> text speakup_synth=ltlk noapic
> Suggestion 2:
> Get your girlfriend to boot into BIOS and disable ACPI in the BIOS, save and
> exit, and boot again.
> I'm betting that your system uses nvidia nforce on the system chipset. You
> are not alone with this APIC error.
> Corey Knapp wrote:
>> Hi
>> My girl friend was here and here is what she saw on the screen
>> Timer: vector=0x31 apic1=0 Pin1=0 apic2=-1 Pin2=-1 MP-BIOS bug: 8254 
>> Timer not connected to Io-APIC Trying to set up timer (IRQ0) Through 
>> The 8259A.Failed Trying to set up timer as Virtual Wire IRQ.Failed 
>> Trying to set up timer as ExtINT IRQ. Failed :( .
>> Kernel Panic- not syncing: IO- Apic + timer doesn't work!  Boot with 
>> apic=debug and send a report.  Then try booting with the 'noapic' option.
>> Thanks in advance.
>> Corey

More information about the Speakup mailing list