need help getting fedora 6 to boot with speech

Janina Sajka janina at
Sat Feb 10 17:54:23 EST 2007

The specific messages you posted the other day are your best bet to get
solid advice. Anything else is just wild guesswork which I doubt we'll
even try to do. For instance, I don't think anyone would have guessed
apic, and clearly it was getting in your way. I know it's a pain to have
to pull that kind of data together for an email posting, but it's the
only way.

Corey Knapp writes:
> Hi Dug, 
> I had my girlfriend go and disable apic but now the doubletalk will not
> speak and I have tried the following things.
> 1. text speakup_synth=ltlk speakup_ser=1 and I tried 0 and 2
> It boots fine from the fedora 3 boot.iso any help would be appreciated.
> thanks in advance.
> Corey
> -----Original Message-----
> From: speakup-bounces at [mailto:speakup-bounces at]
> On Behalf Of Doug Sutherland
> Sent: Thursday, February 08, 2007 8:53 PM
> To: Speakup is a screen review system for Linux.
> Subject: Re: need help getting fedora 6 to boot with speech
> Your system is choking before it gets to anything to do with speech. The
> APIC is a programmable interrupt controller. Thats the 8259A in your system.
> The 8254 mentioned is the system timer. It appears that on boot the kernel
> is trying to register the system timer with the interrupt controller and
> it's failing.
> Note what the kernel message states: try booting with the 'noapic' option.
> This is a kernel  parameter.  They can be specified at the boot prompt.
> Suggestion 1:
> text speakup_synth=ltlk noapic
> Suggestion 2:
> Get your girlfriend to boot into BIOS and disable ACPI in the BIOS, save and
> exit, and boot again.
> I'm betting that your system uses nvidia nforce on the system chipset. You
> are not alone with this APIC error.
> Corey Knapp wrote:
> > Hi
> > My girl friend was here and here is what she saw on the screen
> >
> > Timer: vector=0x31 apic1=0 Pin1=0 apic2=-1 Pin2=-1 MP-BIOS bug: 8254 
> > Timer not connected to Io-APIC Trying to set up timer (IRQ0) Through 
> > The 8259A.Failed Trying to set up timer as Virtual Wire IRQ.Failed 
> > Trying to set up timer as ExtINT IRQ. Failed :( .
> > Kernel Panic- not syncing: IO- Apic + timer doesn't work!  Boot with 
> > apic=debug and send a report.  Then try booting with the 'noapic' option.
> > Thanks in advance.
> > Corey
> _______________________________________________
> Speakup mailing list
> Speakup at
> _______________________________________________
> Speakup mailing list
> Speakup at


Janina Sajka				Phone: +1.202.595.7777
Partner, Capital Accessibility LLC	http://CapitalAccessibility.Com

Marketing the Owasys 22C talking screenless cell phone in the U.S. and Canada--Go to http://ScreenlessPhone.Com to learn more.

Chair, Accessibility Workgroup		Free Standards Group (FSG)
janina at

More information about the Speakup mailing list