trying to use brltty to install debian etch on mac mini

Michael Whapples mwhapples at
Sun Dec 9 14:06:50 EST 2007

I may not have the actual answer, but here are some things that strike
me about this and might help in finding the answer.

Firstly I have noticed that brltty seems to be able to communicate to
your display without problems, it can show screen not in text mode with
out a problem (it doesn't come up as question marks). This indicates the
problem is somewhere in the screen driver side of things. I don't know
what might be the problem there. One possible solution (if it exists)
would be is there an ubuntu version for powerpc with orca? If so this
would not be using any of the brltty screen drivers as orca directly
interfaces to brltty through brlapi. Also from what you have said it
sounds like the powerpc debian CD installer uses a graphical interface,
does the X86 version also use this (I mean if you start brltty the same
way as you said you have on the powerpc version as starting it from the
boot prompt might change something and it might then not use the default
installer)? If yes to that, do you know what is being used in the X86
debian installer to tell brltty what to output?

Ideally you probably want to try and find a solution to make the brltty
screen driver work properly.

Michael Whapples
On Sat, 2007-12-08 at 23:44 -0600, Cheryl Homiak wrote:
> I've tried posting about this problem to the brltty list. I also tried 
> subscribing to the ubuntu-accessibility list but haven't gotten back a 
> confirmation email. so, while i know it's about brltty rather than 
> speakup, I hope somebody can help me. I really would like to install 
> debian as a second system on my apple mac mini. The reason ubuntu is also 
> discussed here is that I tried using the ubuntu powerpc live cd to try to 
> troubleshoot my problem with the debian netinst powerpc installer.
> My status with trying to get brltty to work with the debian etch netinst CD
> now turns out to be the same as that of trying to run brltty in ubuntu. With
> both the debian netinst and ubuntu in x86 versions, I have no problem with
> brltty. When using the corresponding cds for the powerpc architecture,
> brltty does start but then gives me nothing but question marks.
> with the ubuntu cd I simply booted and then went to a text console and typed
> brltty -b bl -d ttyUSB0
> I could see
> brltty 3.7.2
> but after that I got the rows of question marks. I could hear the display
> pins changing as I arrowed or typed but all remained question marks.
> With the debian etch netinst for powerpc, which is also using brltty 3.7.2,
> when I tried to get brltty on boot by typing
> install brltty=bl,ttyUSB0
> I got nothing.
> so instead, just to see what would happen, I just hit enter at the boot
> prompt and then switched with alt-f2 and hit enter to be in a console. there
> I typed
> brltty -b bl -d ttyUSB0
> and hit enter. Brltty 3.7.2 came up but just as on ubuntu in powerpc, I then
> got the rows of question marks. Then when I did alt-f1 to go back to the
> installer, I got
> screen not in text mode
> If I do the same thing on the x86 installer cd, switching back to the 
> installer gives me perfectly readable braille.
> somebody has already suggested that I might need to add the text table 
> designation, but this shouldn't be necessary (isn't necessary in the 
> corresponding x86 cds) and doesn't help.
> does anybody know what is wrong here and is there anything I can do about
> it? Since the x86 versions of these CDs work and the ppc versions don't 
> for me,
> I'm assuming it has something to do with running brltty on a CD with ppc
> architecture. If I can solve this, I can very probably accomplish my goal of
> having a dual boot mac mini with debian and macosx.
> TIA.
> -- 
> Cheryl
> "Where your treasure is, there will your heart be also."

More information about the Speakup mailing list