What's with this error?

Toby Fisher toby at tjfisher.co.uk
Tue Dec 3 10:30:55 EST 2002

Hash: SHA1

On Mon, 2 Dec 2002, Janina Sajka wrote:

> I'm trying to setup some firewalling rules using the endoshield script.
> This is on a DEC Alpha running Debian Woody with the 2.4.20 kernel. I'm
> fully updated based on apt-get.
> When I run the script I get:
> /lib/modules/2.4.20/kernel/net/ipv4/netfilter/ip_tables.o: insmod
> ip_tables failed
> iptables v1.2.6a: can't initialize iptables table `filter': iptables
> who? (do you need to insmod?)
> This happens whatever I do to /etc/init.d/iptables. -- halt, stop,
> start, etc. Actually, "start" doesn't work, complains about an "unknown
> rule set."
> If I try to modprobe ip_tables, I get the same error. If I try rmmod,
> I'm told it isn't loaded, and indeed, it doesn't show with lsmod.

Sounds like you've got iptables compiled straight into the kernel, just
edit the script and comment out the lines that try to load the iptables
module.  This is done so that people can have a system using either
iptables or ipchains.  I had a similar problem, but a few comments in the
right places means that it now runs error-free.


- -- 
Toby Fisher	 Email: toby at tjfisher.co.uk
Tel.: +44(0)1480 417272	Mobile: +44(0)7974 363239
ICQ: #61744808
   Please avoid sending me Word or PowerPoint attachments.
   See http://www.fsf.org/philosophy/no-word-attachments.html

Version: GnuPG v1.2.1 (GNU/Linux)
Comment: pgpenvelope 2.10.2 - http://pgpenvelope.sourceforge.net/


More information about the Speakup mailing list