rap problem solved!

Jacob Schmude jacobs at ncinter.net
Mon Apr 3 22:40:03 EDT 2000


I got my rap problem solved under slackware and am now running realaudio
perfectly. I'm giving a description of what the problem was and how to fix
it, in case someone may have the same problem that I have on slackware. It
seems to be slackware-specific because of the way they set up the Xvfb

The problem simply was that I could not use Xvfb as a user. Many thanks to
Kirk for helping me with this part of it. In any case, to fix it I did:
chmod 4755 /usr/X11R6/bin/Xvfb

This puts the setuid root bit on Xvfb so it can be used by normal
users. The second problem is related to slackware's shell. It uses bash
2.03 and for some reason rap doesn't like it. So, you need to install
bash1.tgz from the a set and then edit the rap script. At the very top
line you'll see #!/bin/sh. Change this to read:

and save the file. That's what my problem was.

Mr. Chuck Halenbeck (excuse spelling, please) may want to keep this in
mind as he is using slackware and will probably encounter this annoyance.

You don't need to install raconfig.tgz to use realplayer 7. rpg2 has
expired, I think.

More information about the Speakup mailing list