rap script problem on slackware

Jacob Schmude jacobs at ncinter.net
Mon Apr 3 21:04:23 EDT 2000

Well Kirk, the seg fault is in the script itself. I put the setuid bit on
Xvfb and it works fine now. When I run rap realplayer seg faults, but when
I run it manually like this:
export DISPLAY=localhost:0.0
Xvfb :0 &
realplay &

I here the welcome sound. So now its just a matter of figuring out the 
script, I may need to write my own script from scratch.

Here's my shell specs from the control-x control-v command:
GNU bash, version 2.03.0(1)-release (i386-slackware-linux-gnu)

I think it may be a shell problem, I'll make rap use bash 1.14.7 and see
what that does to it.

On 3 Apr 2000, Kirk Reiser wrote:

> Jacob Schmude <jacobs at ncinter.net> writes:
> > A reboot is not the problem and XFS isn't even installed. Odd, I only get
> > this error when I'm a user. When I'm root, the RAP script loads Xvfb fine
> I have seen this behaviour on one other system which we ended up
> setting the xvfb server with the euid bit on.
> > but seg faults when trying to load realplayer. How would I give the user
> > the ability to connect to the Xvfb server?
> This one looks like either the raconfig.tgz wasn't installed or at
> least wasn't installed in the root home directory.
>   Kirk
> -- 
> Kirk Reiser				The Computer Braille Facility
> e-mail: kirk at braille.uwo.ca		University of Western Ontario
> phone: (519) 661-3061
> _______________________________________________
> Speakup mailing list
> Speakup at braille.uwo.ca
> http://speech.braille.uwo.ca/mailman/listinfo/speakup

More information about the Speakup mailing list