Bug#735202: Fwd: speakup freezes when trying to past (fwd)

Jude DaShiell jdashiel at shellworld.net
Sat Feb 1 16:07:00 EST 2014

jude <jdashiel at shellworld.net>

---------- Forwarded message ----------
Date: Mon, 13 Jan 2014 14:49:54
From: Paul Gevers <elbrus at debian.org>
To: submit at bugs.debian.org
Subject: Bug#735202: Fwd: speakup freezes when trying to past
Resent-Date: Mon, 13 Jan 2014 19:51:06 +0000
Resent-From: Paul Gevers <elbrus at debian.org>
Resent-To: debian-bugs-dist at lists.debian.org
Resent-cc: Debian Accessibility Team <debian-accessibility at lists.debian.org>

Package: speakup
Severity: critical
Justification: hangs the system which can cause serious data loss

Forwarded the following message as a proper bug report, such that it
isn't lost:

-------- Original Message --------
Subject: speakup freezes when trying to past
Date: Sat, 11 Jan 2014 22:16:58 -0500
From: Doug Smith
To: debian-accessibility at lists.debian.org
Message-id: <20140112031658.GA3563 at Enterprise>

Ok, folks, here's a strange one.  Recently, the kernel in debian testing
was upgraded to 3.12.  When I saw it in the upgrades, I thought: "Well,
nice, it will be interesting to see what kind of hardware support we
have here."  However, the following thing happened one night when my
girlfriend tryed to youtube-dl on her machine which has the same system
as this.  The system froze up completely.  She called me close to
midnight on Monday night, January 6 and asked me to come over to see if
I could unfreeze her system.  The speech had gone out and she couldn't
get it to talk or do anything.

Since we are in neighboring rooms at the facility in which we live, I
got up, got dressed and went over there.  When I got there, I tried
everything to unlock her system.  I finally had to press the power
button.  I asked her what she had done and she told me that she had
tried to youtube-dl.  I tried the same thing she had done with the same
results.  The next day, I tried it on my system with the same result.

I can reproduce this with no problem, but, because it locks the entire
system up, no changing consoles, no speech, nothing works, I have no way
to file a bug report on it.  However, I found out what the problem was.

It wasn't the youtube-dl, it was with speakup.  To reproduce, do this:

1. Using the latest kernel in debian testing, which is 3.12, cut some
text from anywhere you want.
2. paste this text, if you can, using speakup's cut and paste features,
and watch what happens.  Within a few Ms, your system is totally frozen
and will not do anything.

3. Try to get it unlocked.  It won't work.  There is no speech, no
system messages, no changing consoles, no getting at anything of
importance to find out what happened.

The two machines in question are an Acer Aspire 1, in my girlfriend's
case and a Compaq CQ-61 in my case.  This is using the 64-bit
architecture with the entire system functioning perfectly with this

I am not sure what has happened, but I hope it will be fixed soon.  We
have had one of these command line debian installs for several months
and the other one was just done a week ago.

More information about the Speakup mailing list