Still no serial speech with 32-bit Wheezy

Tony Baechler tony at
Mon May 27 21:18:50 EDT 2013

Hash: SHA256

Hi all,

As I posted here a while ago, I was going to do a new, fresh install of
Debian Wheezy to see if I could get working serial speech with a 32-bit
kernel.  I normally run 64-bit kernels exclusively here, but I had an
extra partition serving no useful purpose and I wanted to try a fresh
install with Orca to see how well everything worked.  I'm happy to say
that the install went smoothly and both Speakup and Orca came up on boot.
 For the first time, I had a talking gdm3 login and everything just worked
as it should.  Software speech also came up fine.

What I previously posted was that if I attempted to load a hardware
Speakup module, the system completely locked up.  That is no longer the
case, but I still don't get hardware speech.  After switching to a text
console and logging in as root, I did the following, all on one line:

pkill espeakup;rmmod speakup_soft;rmmod speakup

That left me with no speech.  Just to make sure, I then ran the following:

pkill espeak

Then, I ran the following:

modprobe speakup_dectlk

I got no speech, but the system didn't lock up.  I confirmed this by
launching espeak by itself and entering text which was spoken as normal.
I repeated the rmmod commands to remove any Speakup modules and again
loaded speakup_dectlk but redirecting to /dev/ttyS0 so I could hear any
error messages.  I got silence.  I then typed "halt" and the system halted
as expected.  Therefore, at least on my system, I still have no hardware
speech, even with a 32-bit install.  Wheezy uses the 3.2 kernel, so maybe
a fix made it into a later kernel version.  I could try upgrading to a
newer kernel, but I would like to keep the system as close to stable as
possible for now since I have a talking desktop environment.

It's still a complete mystery to me how anyone here seems to have working
serial support in 3.X kernels.  Apparently a 32-bit install doesn't seem
to make any difference.  I'm glad to try any reasonable experiments since
it's on an extra partition anyway.

Version: GnuPG v1.4.11 (MingW32)
Comment: Using GnuPG with Thunderbird -


More information about the Speakup mailing list