Serial ports with 32-bit vs. 64-bit processors

Tony Baechler tony at
Fri May 17 01:51:42 EDT 2013

Hash: SHA256

I was using speakup_ltlk as an example.  I'm actually using the DECtalk
Express.  I installed Debian unstable a long time ago, so it's possible
that I ran into a bug which is now fixed.  I'm pretty sure it installed
kernel 3.2, but I would have to check.  Since I had no serial support, I
installed with software speech, so speakup_soft is loaded at boot.  X is
also loaded, but I don't have speech in X, so I don't think that's an
issue.  The broken X is apparently my fault as I installed the
gnome-desktop metapackage after D-I, so it doesn't bring in Orca
automatically.  If I go to a regular console and login as root, I get
software speech with Speakup.  If I kill espeakup and unload speakup_soft,
no problem.  As soon as I load speakup_dectlk, the system completely locks
up.  I know it's locked up because I can't reboot.  Trying to play any
sound or calling espeak by itself to produce speech results in silence.  I
have to do a hard reset.  I haven't tried it on my Wheezy server with
kernel 3.2 because I don't want it going down.  I do need to do a fresh
install of Wheezy though to see if some of these issues got fixed.  I
didn't report it as a bug because I assumed it had to do with the broken
serial support.

I can also add that I did test hardware speech with both the Ubuntu and
Wheezy live CDs.  I don't remember the Ubuntu version, but it was recent.
 I think it was 12.04 or 12.10, but I don't remember.  On the Wheezy live
CD, it definitely had kernel 3.2.  Since it doesn't load any Speakup
modules by default, it didn't lock up, but it didn't talk either.  I had
to install espeakup by hand which brought in the espeak packages and
seemed to work.  Since Squeeze still worked reliably, I used that for the
install to the server.  I still run 2.6.32 on my other Linux partition and
hardware speech works fine with my DECtalk Express.

On 5/16/2013 7:59 AM, John G. Heim wrote:
> Are you saying you can't get your doubletalk to work at all or only if
> you load the speakup_sot module before loading the speakup_ltlk module?
> I don't know if I've ever tried that. But  I have a 64 bit machine
> running squeeze and another running wheezy. Speakup works with my
> doubletalk on either machine if I load the speakup_ltlk module
> directly. On the squeeze, I'm running a kernel from squeeze-backports
> and on the wheezy machine, I'm running the stock kernel. Here  is what
> uname -r says on each; squeeze: 3.2.0-0.bpo.4-amd64 wheezy:
> 3.2.0-4-amd64
> My doubletalk also works with the 64-bit grml live CD.   As I said, I'm
> not entirely sure I ever tried loading the speakup_ltlk module after 
> speakup_soft. I would have to say that I have though because I put 
> speakup_soft in /etc/modules so it loads during boot.
Version: GnuPG v1.4.11 (MingW32)
Comment: Using GnuPG with Thunderbird -


More information about the Speakup mailing list