Pulling my hair out over a micro SD

JP Jamous JP at Jepelsy.com
Mon Mar 22 18:43:52 EDT 2010


Looks like Windows corrupted the NTFS. Although NTFS is better than FAT as
they say, It has major problems on the low level.

Try to put the card in the same Windows machine. Use the same profile you
used when you tried copying the files in the first place. Then, try to do a
complete format on the card without  enabling compression.

Right click on the drive letter and make sure under properties the security
tab has everyone in it. It is a Windows profile if you have XP Pro or any
other Windows greater than XP with an edition higher than home. Then, use
your phone or MP3 player to wipe the card.

I hope those help. If not, feel free to e-mail me off the list if the
members do not want to cover Windows on here. At this point, it looks like a
file system problem, but it could also be the device itself. You have to
isolate the possibilities one by one.

-----Original Message-----
From: speakup-bounces at braille.uwo.ca [mailto:speakup-bounces at braille.uwo.ca]
On Behalf Of Georgina Joyce
Sent: Monday, March 22, 2010 6:19 PM
To: speakup at braille.uwo.ca
Subject: Pulling my hair out over a micro SD

        I wondered if anyone could help?
        I've purchased a 16Gb micro SD Sandisk card for a MP3 player.  I
        purchased one with a SD adapter because I don't have a micro HC
        compliant reader.  I put the card in the player and was able to copy
        files onto the card via Windows.  But I got tired of copying my oggs
        stopped after copying about 6Gig.  But what ever I do now I can't
        any more.  Furthermore, I can't destroy it either.  If I run fdisk
        press 'o' for a new partition table the linux machine sits there for
        minute or two and returns me to the prompt.  Then when I list
        'fdisk -l' it's vanished.  I've been reading forums about Sandisk
        and my head is spinning.
        What logs or switches should I observe what is going on?
        I found ufiformat a low level format tool but it refuses to identify
        SD as a floppy, obviously because it's not.  So is there another
tool I
        BTW: There's a HP USB storage format tool that doesn't touch it
        on the Windows platform.  This is why I thought I've have better
luck on
        I've tried mkfs.vfat again it returns me to the prompt after several
        minutes having not touched the file system on the card.

I could touch a test file and rm that file.  But If I attempt larger file
transfers the device craps out with read write errors and the device has
        As Micro SD's don't have a locking switch how on earth do I get this
        thing formatted and start again?
        Something has had some effect as it's currupted something as the
        player just crashes when I attempt to use it with the card inserted.
        I'm waiting for a new card reader but I don't think that's going to
        any difference because I've tried to get my phone to format it.
        Victor Stream too.  None of them can touch this card.
        Well I have destroyed partition tables with dd before now but
        have a clue on whether this would help in this situation.
        Any help would really be appreciated.
        Yours frustrated. 


four kinds of freedom, for the users of the software:

    * The freedom to run the program, for any purpose (freedom 0).
    * The freedom to study how the program works, and adapt it to your
needs (freedom 1). Access to the source code is a precondition for this.
    * The freedom to redistribute copies so you can help your neighbor
(freedom 2).
    * The freedom to improve the program, and release your improvements
to the public, so that the whole community benefits (freedom 3). Access
to the source code is a precondition for this.

Richard Matthew Stallman

Speakup mailing list
Speakup at braille.uwo.ca

More information about the Speakup mailing list