Latest Lenny kernel and ltlk module crash my system

Al Sten-Clanton Albert.E.Sten_Clanton at
Fri Sep 5 11:47:19 EDT 2008

I've had the speech output problem you describe through several versions of
Fedora, and also a time or two, I think, after installing Debian via the
mini-beep.iso.  Very lately, I've avoided rebooting by hitting the key that
kills and revives Speakup.  I typically had to hit it a few times, and
finally Speakup would say "I'm alive."  I then quickly decrease and increase
the speech rate and volume, and things seem as before.  I realize that ain't
no real fix, and I know nothing about how to do a real fix.  I also realize
you may have tried that and it failed, but thought it worth suggesting


-----Original Message-----
From: speakup-bounces at [mailto:speakup-bounces at]
On Behalf Of Chuck Hallenbeck
Sent: Friday, September 05, 2008 5:14 AM
To: Speakup is a screen review system for Linux.
Subject: Latest Lenny kernel and ltlk module crash my system


A week ago Michael reported a problem after upgrading his Debian system
to kernel 2.6.26-1 with the associated speakup modules. His ltlk could
not handle lengthy outputs, and locked up his system completely. I had
just experienced an identical problem with an identical configuration,
and was hoping for a solution. My system worked reliably with the soft
driver using espeakup and espeak in the meantime. Both Michael and I
were working from a fresh Lenny install from Samuel's mini-beep iso, I
believe. We began with the 2.6.25-2 kernel and modules available on
installation, and the crashes only began when upgrading to 2.6.26.

A day or two ago an upgrade appeared for the 2.6.26-1 kernel, but not
for the modules. Both Michael and I installed the upgrade. He reports
that for him the upgrade solved his ltlk crashing. However, for me it
did not. So I am once again using software speech hoping that a fix may

Here is a reliable way to crash my system with the currently available
Debian packages for kernel 2.6.26-1 and the speakup 2.6.26 modules:

My console is set to 48 lines of 128 characters with the boot parameter

My email client, mutt, has a folder containing about 60 messages. When
I open that folder with mutt, the screen fills with the index of
messages, and my ltlk begins to read the entire screen starting at the
top. I try to silence the speech with the numpad enter key, but there
is no response. Reading continues. In fact my keyboard seems
unresponsive. Cannot change consoles, exit mutt, stop the speech. In
desperation I issue the three-finger-salute (ctrl-alt-delete) expecting
it too to fail, but it worked. I brought the system down that way.
After rebooting I reverted once again to software speech.

I am most anxious to simplify my maintenance requirements here, and
was hoping to be able to rely on the newly available Debian packages
which seemed to offer such promise. 

Are there others who are using this configuration with success? i.e.,
the Debian kernel and speakup modules for 2.6.26 with the doubletalk LT
(the ltlk) driver? If so, and your system can survive a lengthy text
stream sent to your synth, then perhaps my problem is the synth itself
rather than the supporting software. Fortunately my software speech
setup is robust and responsive.



The Moon is Waxing Crescent (29% of Full)

My web site: -- my telephone: 1-518-334-9022.
Exhilaration is that feeling you get just after a great idea hits you,
and just before you realize what is wrong with it.
Speakup mailing list
Speakup at

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 270.6.16/696 - Release Date: 9/3/2008
12:00 AM

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 270.6.16/696 - Release Date: 9/3/2008
12:00 AM

More information about the Speakup mailing list