Debian on Older Equipment?

Steve Holmes steve at
Fri Nov 14 13:06:03 EST 2008

Hash: RIPEMD160

I wondered about that.  Sometimes I think this initrd stuff just makes
things more complicated.  I see their value for early loading of
modules and stuff, but eventually, you need all necessary modules to
be loaded either from the full kernel or from the initrd and handed
off.  It's hard for me to really appreciate the difference.  This kind
of thing is probably most useful for installers where the main disk
hasn't been allocated yet.  

The installation docs claim Deb will run on 32 megs but I'm sure
that's the bare minimum.  Is there any reason Speakup couldn't have
been included in the text installer? Wouldn't that reduce the resource
requirements for this? If I some how get the machine to boot with the
text installer, could I dynamically load speakup by modprobing speakup
and specifying the synth module?

I just wanna see if I can get Debian installed on this box.

On Fri, Nov 14, 2008 at 04:14:35AM -0500, luke wrote:
> My guess: a problem with the ramdisk which the installer uses as a working 
> system.
> I wonder if there is a way to have it run as a livecd?
> On Thu, 13 Nov 2008, Steve Holmes wrote:
> > Hash: RIPEMD160
> > 
> > I have an old Toshiba laptop Satelite 300 with a wappin' 32 megs of
> > memory with a 266 MHz processor.  Slackware runs fine on it but I
> > thought I would try to install Debian Lenny on it but I can't get
> > speakup to come up at all.  Is there a chance that Debian's kernels
> > just don't work on this little pup? I tried the usual procedure with
> > both a full CD for I386 and the netinst disk for I386 downloaded today
> > and I did the down arrow once followed by tab then
> > 'speakup.synth=spkout'.  The disk cycled up at the appropriate times
> > but silence.  I verified that this disk and procedure work on another
> > machine and it talked OK.  I even tried an additional option of
> > 'fb=false' thinking maybe it were a framebuffer.  Still no go.  I
> > experimented once by specifying 'console=ttyS0,9600,n,8' and listened
> > to see if the Speakout would talk at all and sure enough, it did.  It
> > appeared to me that the kernel actually came up but there was a lot of
> > stray characters (probably for terminal control or something) but it
> > proved to me that the kernel appears to boot and my serial connection
> > to the laptop is good.
> > 
> > So after all this messing around, is Debian too big for my laptop? I
> > guess I could keep on with Slackware as that still works fine.  I was
> > just thinking I would begin to switch all my boxen over to Debian.
> > 
> > Any ideas?
> > Version: GnuPG v1.4.9 (GNU/Linux)
> > 
> > iEYEAREDAAYFAkkc764ACgkQWSjv55S0LfG4xgCfdkjhd1P6uUSFIRjNsBpOqq7k
> > Lp8AoLRXm9w3wTCFWjnAp1PeqCYL8zuT
> > =q5jz
> > -----END PGP SIGNATURE-----
> > _______________________________________________
> > Speakup mailing list
> > Speakup at
> >
> > 
> _______________________________________________
> Speakup mailing list
> Speakup at
Version: GnuPG v1.4.7 (GNU/Linux)


More information about the Speakup mailing list