two problems installing software speech with speakup

Gary Cramblitt garycramblitt at
Thu Jun 29 18:31:11 EDT 2006

On Thursday 29 June 2006 17:15, Charles Hallenbeck wrote:
> 1. With festival, speech-dispatcher, speechd-up, and a current version
> of speakup patched into a 2.6.17 kernel, activating software speech
> failed because the /dev/softsynth device was not created by udev on the
> new machine. This happened automatically on my own system, but not on
> the new system.
> Solution: On the system that worked okay, the kernel configuration
> specified that sftsyn was compiled into speakup. On the new system, it
> was compiled as a module. Changing this kernel compile option to "y"
> instead of "m" solved the problem. A check of the readme.debian file
> with udev explained the problem, but it took me forever to dig that
> deeply to discover it.

Are you saying that sftsyn cannot be loaded as a module and *must* be compiled 
into the kernel, or is it a matter of forcing a load of the sftsyn module 
(/etc/modules) and properly configuring udev?

BTW, I'm not a SpeakUp user myself and cannot investigate this, but it struck 
me as strange that sftsyn would be distributed as a module if it cannot be 
used as a module.
Gary Cramblitt (aka PhantomsDad)

More information about the Speakup mailing list