installing slackware over serial line

Gregory Nowak greg at
Fri Jun 25 18:39:28 EDT 2004

Hash: SHA1

I don't know what to tell you. However, if you can't modify the
RAMdisk image, and can't use speakup for whatever reason, there is
another way to bring up a serial console, assuming you can login
without speech.

1. Login into the RAMdisk-based system once you boot. 

2. Do:

cat >/etc/inittab

Then type:

s1:12345:respawn:/sbin/agetty -L ttyS0 9600 vt100

replace ttyS0 if you need to. Then, hit enter, followed by ctrl+d.

3. type:

telinit q

Hopefully, your serial console should come up.

Also note that if you have to use the earlier slackware versions
without speakup in the official distro, I believe the older
speakup-modified slackware disk images are still on bumpy. Hth.


On Fri, Jun 25, 2004 at 05:01:54PM -0400, Alex Snow wrote:
> Hi all.I'm trying to install slackware over a serial line. When the disk 
> loads I type ramdisk console=ttyS0 and press enter. after the disk loads 
> all the messages show up on my serial terminal. at the "insert root 
> floppy disk to be loaded into ramdisk and press enter" prompt, I put in 
> my rootdisk and hit enter on the terminal. nothing. it doesn't even try 
> the drive. it's like I didn't press any key at all. I try hitting enter 
> on the keyboard atached to the pc that I'm installing on. nothing 
> happens then either. I've tried with slackware 7.1 and 8.0 with the same 
> results. for terminal packages I've tried both hyperterminal and 
> teraterm. any suggestions would be greately apreciated.
> -- 
> Whoa...I did a 'zcat /vmlinuz > /dev/audio' and I think I heard God...
> 	-- mikecd on #Linux
> _______________________________________________
> Speakup mailing list
> Speakup at
> !DSPAM:40dc9e2d320082142915174!

- -- 
Free domains: or mail dns-manager at

Version: GnuPG v1.2.3 (GNU/Linux)


More information about the Speakup mailing list