Dectalk ISA model

Gene Collins collins at
Wed Jun 23 10:16:38 EDT 2004

Hi Debee.  The dtload you should be using is in the gz file you
downloaded from speakup.  I don't remember whether it is in source or
binary form, but probably source.

You build the decpc module when you configure your kernel.  Instead of
answering y for this module, you answer m.  Then you run make modules
and as root make modules_install in order to build and install the
module.  You can also get help, by typing a question mark (?) while you
are sitting on the decpc choice in the configuration process.  To make
this even easier, use make menuconfig instead of make config.  The
Speakup synthesizer choices are under the console configuration choice.

Try using the firmware in the decpc.tar.gz file first.  If that doesn't
work, you can try substituting your dos firmware.

Hope this helps.


>I still haven't gotten dtload to talk to my DecPC2. Has anyone tried it with
>a PC2?
>I'm now using CVS speakup and kernel 2.4.26. Speakup is happily talking to
>serial synths.
>I've tried using the firmware for my card, also tried using the firmware
>that was bundled with this dec_pc.tgz that was on the speakup site.
>I compiled the dtload source like this:
>	gcc -O -o dtload dtload.c
>the Readme says that the uppercase O flag is necessary for the I/O
>instructions to work.
>This Readme, which wasn't in the speakup documentation but was in the
>Dec_pc.tgz on the speakup site also shows this usage:
>>dtload [-v] [-t] [path]
>>-v is verbose (gives all kinds of loading info )
>>-t is test mode. takes what you type and says it.
>>eof to quit the program in test mode.
>The -v definitely is verbose. There are no errors; every firmware module
>appears to load in to the card fine. It shows the address of where it is
>loading and also some displays of registers.
>However after all that, it exits with a status of -9 or -3.
>And the -t test mode doesn't work. It never talks. Eof does exit without
>crashing the first time; second time I try to use it in the current session,
>it crashes. And not just that process hangs, the whole system hangs. I have
>gotten to be real good friends with e2fsck and  where copies of my
>superblock live ..
>The Readme goes on to say:
>>basic operation after the module is built and installed is:
>>echo decpc >/proc/speakup/synth
>What module? Was I supposed to build this dtload as a module? How? You know
>I'm not even sure this is the right Readme for this dtload. I need to find a
>package where the Readme and source for sure match.
>And changing the synthesizer simply crashes Speakup, no doubt because the
>Dectalk isn't really "there" yet.
>I'm eager to get this working because I want my serial port back.
>       --   Debee
>Speakup mailing list
>Speakup at

More information about the Speakup mailing list