Compiling My Kernel -- still having trouble

Alex Snow alex_snow at
Tue Jun 15 16:44:49 EDT 2004

Hash: SHA1

I don't think you'll have to update any module init tools under 
slackware 9.1 The docs say it's fully 2.6 ready and has all that stuff 
On Tue, Jun 15, 2004 at 09:25:54AM -0500, Gene Collins wrote:
> Hi Debee.  You need to use at least 2.4.25 source for the cvs version of
> speakup.  If you want to use the cvs version, then you should * NOT *
> try to install the 1.5 patches first.  They are incompatible.  If you
> want the dectalk isa card support then you should only use the 2.4.25 or
> later source with the cvs version of speakup.
> If you want to use some other synthesizer, then you could use the 1.5
> version of Speakup, though with all the new features of the cvs version,
> I can't see why you'd want to.  Just untar a fresh 2.4.25 or preferable
> 26 source tree, run make mrproper, and then run the checkout script. 
> You might even consider jumping all the way up to the 2.6 kernels,
> though you'll have to install the module-init-tools if you want to do
> that.  It has lots of advantages, including built-in alsa drivers in the
> kernel. Hope all this helps.
> Gene
> >I spent most of my weekend trying to compile a Speakup-enabled kernel. The
> >good news is I compiled several stock kernels, without speech and without
> >errors. I can boot them; they locate and support all my hardware fine. I can
> >telnet in to the machine and even mount my USB flash drive.
> >
> >But I get errors every time I try to patch in Speakup.
> >
> >I have been careful to completely remove the entire source tree and untar a
> >brand-new tree to /usr/src. I create the soft link so linux-2.4.22 points to
> >/usr/src/linux. This is Slackware 9.1, kernel version 2.4.22. I've tried
> >using the source tree that is part of my distro; also downloaded a new
> >2.4.22 tree from
> >
> >I tried installing Speakup 1.5 and I also tried getting the 2.26 from CVS. I
> >tried doing the 1.5 first, then the cvs patches.
> >
> >If I ignore the patching errors and do make oldconfig, I am prompted for the
> >new things, like all the synthesizers, including the Dectalk ISA card. The
> >speakup directory is there under /usr/src/linux/drivers/char,  and lots of
> >source and header files are there as well. But of course, this patched
> >kernel doesn't compile.
> >
> >I've read all the documentation I could find and that was recommended on
> >this list, but I'm obviously missing something.
> >
> >Here's a snip from the patching output:
> >
> >U speakup/diff-v26/include^linux^speakup.h.copy
> >Creating .orig files [..................] done.
> >Patching files [pppppppppp1 out of 3 hunks FAILED -- saving rejects to file
> >/usr
> >/src/linux/drivers/char/Makefile.rej
> >ppppppp] done.
> >Copying files [ccccc] done.
> >
> >--Debee
> >
> >
> >
> >
> >_______________________________________________
> >Speakup mailing list
> >Speakup at
> >
> _______________________________________________
> Speakup mailing list
> Speakup at

- -- 
By golly, I'm beginning to think Linux really *is* the best thing since
sliced bread.
	-- Vance Petree, Virginia Power
Version: GnuPG v1.2.3 (GNU/Linux)


More information about the Speakup mailing list