thinkpad: serial port working now!!!

Brian Borowski brianb at
Thu Aug 22 22:20:05 EDT 2002

If you can't use the cdrom, what we've often done, is to go through the
installation on floppies, get the ethernet card operational, set an IP
address ETC, and use nfs to another of your local machines.  You must have
nfs server on the other machine, and put the base.tar.gz  on that machine
in a place where you can get at it through nfs.  Then select the mount nfs
option, and complete the install that way.  This is just a rough outline of
how to do this, but I've often done it this way, when it wasn't easy to
have the thing on cdrom or the cdrom wasn't usable for some reason.

Brian Borowski

On Thu, 22 Aug 2002, Cheryl Homiak wrote:

>  I always say I'm going to give up on such things, but I can never bring myself
> to quit trying one thing or another!
> I'm not totally sure what finally got it to work. One new thing I did was to go
> to to the thinkpad info at sourceforge and thence to the ftp link for uttpcdos
> (DOS thinkpad utilities). I put these on the floppy with my very barebones
> config.sys and autoexec.bat and booted. I then typed in the lines of ser.bat
> individually rather than running the .bat. I rebooted and tested by sending an
> echo to com1, not really expecting anything. I got a bunch of xxxxxxx back so
> tried the debian boot floppies. speakup came up talking.
> Only, I can see I must get at least the numeric keypad immediately. If I let
> speakup prattle on during the loading of the rescue disk it eventually stops
> talking; this can be fixed by turning it back on via the inser/enter on the
> numeric keypad. haven't tried to figure out yet whether I can do that at that
> stage of loading with the shift+f10; if I can't, doubletalk doesn't start up
> again when I put in the rootdisk so I have no speech.
> Unfortunately, the brltty disks I have aren't working either, but I don't think
> it has to do with the braillelite. I don't get any activity when I put the
> rootdisk in, before i even get to loading brltty, so I think it has something to
> do with the kernel which is 2.2.20, which unfortunately is the default woody
> kernel. the speakup disks I have use 2.4.17. So there's maybe a problem between
> my thinkpad and that 2.2.20 kernel which I will have to eventually sort out.
> One I get over the installation hump, of course, yasr and emacspeak are also
> options.
> One
> thing I am wondering about:  whatever screen reader I use for installation,
> I am doing the first steps with floppies. However, since I don't have my modem
> or ethernet up and running and may not have those until i can compile a special
> kernel and install, I need to install packages by cdrom. Is there any way I can
> switch from the floppy to the cdrom in the ultrabay without turning the machine
> off? Otherwise, I'm going to have trouble installing packages and completing the
> debian 3.0 installation. At one time there was a debian woody speakup iso I
> think, but i don't
> see that now. At any rate, these debian 3.0 are still the pre-release and i
> don't know if that will cause problems or not.
> But i'm pretty happy--I've discovered dos and linux thinkpad utilities and MY
> thanks to all who gave advice.
> Cheryl
> _______________________________________________
> Speakup mailing list
> Speakup at

More information about the Speakup mailing list