I can't get the patch command to work

Charles Hallenbeck chuckh at mhonline.net
Sun Jun 4 18:20:25 EDT 2000

Dave -

I recently patched my own kernel successfully and did it like this:

1. I became root and used 'tar' to unpack two tarballs - one was the
source tree and the other was the speakup package. That created two
directories under /usr/src - /usr/src/linux and /usr/src/speakup-0.09.

2. Then I issued the following patch command:

<prompt># patch -p0 < speakup-0.09/speakup-0.09-v2.2-patch

3. Next I changed directories to /usr/src/linux, where I ran 'make config'
to confkigure my system, then 'make dep', 'make modules', 
'make modules_install', 'make zImage', and finally 'make install'.

4. Next I changed to /usr/src/speakup-0.09/load_spk-0.8 where I ran
'./configure', 'make', and 'make install'.

5. Then I rebooted and up it came talking with everything working.

The kernel I was using was 2.2.15 which I downloaded from
www.us.kernel.org. I am using Slackware and was already running kernel
2.2.14, speakup 0.08, and load_spk 0.6.

-- Oh yes - I forgot - before unpacking the kernel tarball I renamed the
old /usr/src/linux directory to /usr/src/linux-2.2.14 just for savfety,
although I have not referred to it since.

The reason I used the v2.2-patch instead of the v2.3-patch was because I
was patching a 2.2 kernel - namely 2.2.15.

Hope something in this description helps. Be sure your kernel tree is
named 'usr/src/linux' and that it has not already been patched with some
other modifications... Sorry I am not more familiar with Redhat.


My web site is http://www.mhonline.net/~chuckh 
While money doesn't buy love, it puts you in a great bargaining

More information about the Speakup mailing list